My Question is:
I made an upgrade using multibos, everythin is OK, but if i boot with mi new TL hdisk0 and blv=bos_hd5 Aix 6100-TL9, what happens if i run multibos -R ? I lost the bos_hd5 or I lost hd5 ?
I will describe a TL upgrade using multibos on AIX 6.1. The system will be moved from 6100-07 to 6100-09 (TL7 to TL9).
1. Check current TL level
2. Preview/Create the multibos standby BOS instance.
3. Preview/Patch the OS in the standby instance
4. Verify the oslevel in the standby instance after the update
5. Reboot and check
6. Optionally return to the pre-update BOS image.
1.
#oslevel -s
6100-07-02-1150
2.
# multibos -Xsp
Return Status = SUCCESS
==============================================================================
-X automatically extend FS
-s create standby BOS instance
-p preview mode
==============================================================================
Now we actually run the command without preview mode. This may take a while even two.
# multibos -Xs
Initializing multibos methods ...
Initializing log /etc/multibos/logs/op.alog ...
Gathering system information ...
+-----------------------------------------------------------------------------+
Setup Operation
+-----------------------------------------------------------------------------+
Verifying operation parameters ...
Creating image.data file ...
+-----------------------------------------------------------------------------+
Logical Volumes
+-----------------------------------------------------------------------------+
Creating standby BOS logical volume hd5
Creating standby BOS logical volume hd4
Creating standby BOS logical volume hd2
Creating standby BOS logical volume hd9var
Creating standby BOS logical volume hd10opt
+-----------------------------------------------------------------------------+
File Systems
+-----------------------------------------------------------------------------+
Creating all standby BOS file systems ...
Creating standby BOS file system /bos_inst on logical volume hd4
reating standby BOS file system /bos_inst on logical volume hd4
Creating standby BOS file system /bos_inst/usr on logical volume hd2
Creating standby BOS file system /bos_inst/var on logical volume hd9var
Creating standby BOS file system /bos_inst/opt on logical volume hd10opt
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Mounting all standby BOS file systems ...
Mounting /bos_inst
Mounting /bos_inst/usr
Mounting /bos_inst/var
Mounting /bos_inst/opt
+-----------------------------------------------------------------------------+
BOS Files
+-----------------------------------------------------------------------------+
Including files for file system /
Including files for file system /usr
Including files for file system /var
Including files for file system /opt
Copying files using backup/restore utilities ...
Percentage of files copied: 0.00%
Percentage of files copied: 1.35%
...
Percentage of files copied: 98.74%
Percentage of files copied: 100.00%
+-----------------------------------------------------------------------------+
Boot Partition Processing
+-----------------------------------------------------------------------------+
Active boot logical volume is bos_hd5.
Standby boot logical volume is hd5.
Creating standby BOS boot image on boot logical volume hd5
bosboot: Boot image is 43345 512 byte blocks.
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Unmounting all standby BOS file systems ...
Unmounting /bos_inst/opt
Unmounting /bos_inst/var
Unmounting /bos_inst/usr
Unmounting /bos_inst
+-----------------------------------------------------------------------------+
Bootlist Processing
+-----------------------------------------------------------------------------+
Log file is /etc/multibos/logs/op.alog
Return Status = SUCCESS
3. Preview/Patch the OS in the standby instance
Preview TL update
# multibos -Xacp -l /nim_rep/lpp_source/TechnologyLevel/AIX6100-09
...
Log file is /etc/multibos/logs/op.alog
Return Status = SUCCESS
==============================================================================
-X automatically extend FS if required
-a update_all install option
-c Performs a customized update of the software in standby BOS
-p preview
-l location
==============================================================================
Now we can run the update without the -p option
# multibos -Xac -l /nim_rep/lpp_source/TechnologyLevel/AIX6100-09
Initializing multibos methods ...
Initializing log /etc/multibos/logs/op.alog ...
Gathering system information ...
+-----------------------------------------------------------------------------+
Customization Operation
+-----------------------------------------------------------------------------+
Verifying operation parameters ...
Validating install images location /nim_rep/lpp_source/TechnologyLevel/AIX6100-09
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Mounting all standby BOS file systems ...
Mounting /bos_inst
Mounting /bos_inst/usr
Mounting /bos_inst/var
Mounting /bos_inst/opt
+-----------------------------------------------------------------------------+
Software Update
+-----------------------------------------------------------------------------+
Installing software to standby BOS ...
install_all_updates: Initializing system parameters.
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Checking for updated install utilities on media.
install_all_updates: Processing media.
install_all_updates: Generating list of updatable installp filesets.
...
...
...
install_all_updates: Checking for recommended maintenance level 6100-09.
install_all_updates: Executing /usr/bin/oslevel -rf, Result = 6100-09
install_all_updates: Verification completed.
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Result = SUCCESS
+-----------------------------------------------------------------------------+
Boot Partition Processing
+-----------------------------------------------------------------------------+
Active boot logical volume is bos_hd5.
Standby boot logical volume is hd5.
Creating standby BOS boot image on boot logical volume hd5
bosboot: Boot image is 49180 512 byte blocks.
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Unmounting all standby BOS file systems ...
Unmounting /bos_inst/opt
Unmounting /bos_inst/var
Unmounting /bos_inst/usr
Unmounting /bos_inst
Log file is /etc/multibos/logs/op.alog
Return Status = SUCCESS
4.
Verify the oslevel in the standby instance after the update
We can actually now enter the secondary BOS instance like a chroot and check the oslevel
# multibos -S
Initializing multibos methods ...
Initializing log /etc/multibos/logs/op.alog ...
Gathering system information ...
+-----------------------------------------------------------------------------+
Multibos Shell Operation
+-----------------------------------------------------------------------------+
Verifying operation parameters ...
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Mounting all standby BOS file systems ...
Mounting /bos_inst
Mounting /bos_inst/usr
Mounting /bos_inst/var
Mounting /bos_inst/opt
+-----------------------------------------------------------------------------+
Multibos Root Shell
+-----------------------------------------------------------------------------+
Starting multibos root shell ...
Active boot logical volume is bos_hd5.
Script started, file is /etc/multibos/logs/scriptlog.120204105327.txt
MULTIBOS> oslevel -s
6100-09-02-1412
MULTIBOS>exit
Verify the bootlist order
# bootlist -m normal -o
hdisk0 blv=hd5 pathid=0
hdisk0 blv=bos_hd5 pathid=0
5. Reboot and check
# oslevel -s
6100-07-02-1150
bash-3.2# instfix -i | grep ML
All filesets for 6100-00_AIX_ML were found.
All filesets for 6100-01_AIX_ML were found.
All filesets for 6100-02_AIX_ML were found.
All filesets for 6100-03_AIX_ML were found.
All filesets for 6100-04_AIX_ML were found.
All filesets for 6100-05_AIX_ML were found.
All filesets for 6100-06_AIX_ML were found.
All filesets for 6100-07_AIX_ML were found.
.
6. Optionally return to the pre-update BOS image.
If necessary you can return to the initial TL, just change the boot order.
# bootlist -m normal -o
hdisk0 blv=hd5 pathid=0
hdisk0 blv=bos_hd5 pathid=0
# bootlist -m normal hdisk0 blv=bos_hd5 hdisk0 blv=hd5
# bootlist -m normal -o
hdisk0 blv=bos_hd5 pathid=0
hdisk0 blv=hd5 pathid=0
# oslevel -s
6100-09-02-1412
Reboot the server and check with oslevel.
# oslevel -s
6100-07-02-1150
So we are now back on the initial TL.
I made an upgrade using multibos, everythin is OK, but if i boot with mi new TL hdisk0 and blv=bos_hd5 Aix 6100-TL9, what happens if i run multibos -R ? I lost the bos_hd5 or I lost hd5 ?
I will describe a TL upgrade using multibos on AIX 6.1. The system will be moved from 6100-07 to 6100-09 (TL7 to TL9).
1. Check current TL level
2. Preview/Create the multibos standby BOS instance.
3. Preview/Patch the OS in the standby instance
4. Verify the oslevel in the standby instance after the update
5. Reboot and check
6. Optionally return to the pre-update BOS image.
1.
#oslevel -s
6100-07-02-1150
2.
# multibos -Xsp
Return Status = SUCCESS
==============================================================================
-X automatically extend FS
-s create standby BOS instance
-p preview mode
==============================================================================
Now we actually run the command without preview mode. This may take a while even two.
# multibos -Xs
Initializing multibos methods ...
Initializing log /etc/multibos/logs/op.alog ...
Gathering system information ...
+-----------------------------------------------------------------------------+
Setup Operation
+-----------------------------------------------------------------------------+
Verifying operation parameters ...
Creating image.data file ...
+-----------------------------------------------------------------------------+
Logical Volumes
+-----------------------------------------------------------------------------+
Creating standby BOS logical volume hd5
Creating standby BOS logical volume hd4
Creating standby BOS logical volume hd2
Creating standby BOS logical volume hd9var
Creating standby BOS logical volume hd10opt
+-----------------------------------------------------------------------------+
File Systems
+-----------------------------------------------------------------------------+
Creating all standby BOS file systems ...
Creating standby BOS file system /bos_inst on logical volume hd4
reating standby BOS file system /bos_inst on logical volume hd4
Creating standby BOS file system /bos_inst/usr on logical volume hd2
Creating standby BOS file system /bos_inst/var on logical volume hd9var
Creating standby BOS file system /bos_inst/opt on logical volume hd10opt
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Mounting all standby BOS file systems ...
Mounting /bos_inst
Mounting /bos_inst/usr
Mounting /bos_inst/var
Mounting /bos_inst/opt
+-----------------------------------------------------------------------------+
BOS Files
+-----------------------------------------------------------------------------+
Including files for file system /
Including files for file system /usr
Including files for file system /var
Including files for file system /opt
Copying files using backup/restore utilities ...
Percentage of files copied: 0.00%
Percentage of files copied: 1.35%
...
Percentage of files copied: 98.74%
Percentage of files copied: 100.00%
+-----------------------------------------------------------------------------+
Boot Partition Processing
+-----------------------------------------------------------------------------+
Active boot logical volume is bos_hd5.
Standby boot logical volume is hd5.
Creating standby BOS boot image on boot logical volume hd5
bosboot: Boot image is 43345 512 byte blocks.
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Unmounting all standby BOS file systems ...
Unmounting /bos_inst/opt
Unmounting /bos_inst/var
Unmounting /bos_inst/usr
Unmounting /bos_inst
+-----------------------------------------------------------------------------+
Bootlist Processing
+-----------------------------------------------------------------------------+
Log file is /etc/multibos/logs/op.alog
Return Status = SUCCESS
3. Preview/Patch the OS in the standby instance
Preview TL update
# multibos -Xacp -l /nim_rep/lpp_source/TechnologyLevel/AIX6100-09
...
Log file is /etc/multibos/logs/op.alog
Return Status = SUCCESS
==============================================================================
-X automatically extend FS if required
-a update_all install option
-c Performs a customized update of the software in standby BOS
-p preview
-l location
==============================================================================
Now we can run the update without the -p option
# multibos -Xac -l /nim_rep/lpp_source/TechnologyLevel/AIX6100-09
Initializing multibos methods ...
Initializing log /etc/multibos/logs/op.alog ...
Gathering system information ...
+-----------------------------------------------------------------------------+
Customization Operation
+-----------------------------------------------------------------------------+
Verifying operation parameters ...
Validating install images location /nim_rep/lpp_source/TechnologyLevel/AIX6100-09
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Mounting all standby BOS file systems ...
Mounting /bos_inst
Mounting /bos_inst/usr
Mounting /bos_inst/var
Mounting /bos_inst/opt
+-----------------------------------------------------------------------------+
Software Update
+-----------------------------------------------------------------------------+
Installing software to standby BOS ...
install_all_updates: Initializing system parameters.
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Checking for updated install utilities on media.
install_all_updates: Processing media.
install_all_updates: Generating list of updatable installp filesets.
...
...
...
install_all_updates: Checking for recommended maintenance level 6100-09.
install_all_updates: Executing /usr/bin/oslevel -rf, Result = 6100-09
install_all_updates: Verification completed.
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Result = SUCCESS
+-----------------------------------------------------------------------------+
Boot Partition Processing
+-----------------------------------------------------------------------------+
Active boot logical volume is bos_hd5.
Standby boot logical volume is hd5.
Creating standby BOS boot image on boot logical volume hd5
bosboot: Boot image is 49180 512 byte blocks.
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Unmounting all standby BOS file systems ...
Unmounting /bos_inst/opt
Unmounting /bos_inst/var
Unmounting /bos_inst/usr
Unmounting /bos_inst
Log file is /etc/multibos/logs/op.alog
Return Status = SUCCESS
4.
Verify the oslevel in the standby instance after the update
We can actually now enter the secondary BOS instance like a chroot and check the oslevel
# multibos -S
Initializing multibos methods ...
Initializing log /etc/multibos/logs/op.alog ...
Gathering system information ...
+-----------------------------------------------------------------------------+
Multibos Shell Operation
+-----------------------------------------------------------------------------+
Verifying operation parameters ...
+-----------------------------------------------------------------------------+
Mount Processing
+-----------------------------------------------------------------------------+
Mounting all standby BOS file systems ...
Mounting /bos_inst
Mounting /bos_inst/usr
Mounting /bos_inst/var
Mounting /bos_inst/opt
+-----------------------------------------------------------------------------+
Multibos Root Shell
+-----------------------------------------------------------------------------+
Starting multibos root shell ...
Active boot logical volume is bos_hd5.
Script started, file is /etc/multibos/logs/scriptlog.120204105327.txt
MULTIBOS> oslevel -s
6100-09-02-1412
MULTIBOS>exit
Verify the bootlist order
# bootlist -m normal -o
hdisk0 blv=hd5 pathid=0
hdisk0 blv=bos_hd5 pathid=0
5. Reboot and check
# oslevel -s
6100-07-02-1150
bash-3.2# instfix -i | grep ML
All filesets for 6100-00_AIX_ML were found.
All filesets for 6100-01_AIX_ML were found.
All filesets for 6100-02_AIX_ML were found.
All filesets for 6100-03_AIX_ML were found.
All filesets for 6100-04_AIX_ML were found.
All filesets for 6100-05_AIX_ML were found.
All filesets for 6100-06_AIX_ML were found.
All filesets for 6100-07_AIX_ML were found.
.
6. Optionally return to the pre-update BOS image.
If necessary you can return to the initial TL, just change the boot order.
# bootlist -m normal -o
hdisk0 blv=hd5 pathid=0
hdisk0 blv=bos_hd5 pathid=0
# bootlist -m normal hdisk0 blv=bos_hd5 hdisk0 blv=hd5
# bootlist -m normal -o
hdisk0 blv=bos_hd5 pathid=0
hdisk0 blv=hd5 pathid=0
# oslevel -s
6100-09-02-1412
Reboot the server and check with oslevel.
# oslevel -s
6100-07-02-1150
So we are now back on the initial TL.
Comentarios
Publicar un comentario