How to Upgrade Mirrored IBM AIX with Minimal Disruption

AIX provides a very nice way to upgrade the OS while the system us up. It will require two reboots, but the time consuming parts can be done first. This is the process I used to upgrade AIX 5.3, technology level (TL) 4 to AIX 5.3 TL7.

0. Backup the OS

AIX# mksysb

1. Download updates. I downloaded it to an NFS-mounted filer, and it worked okay.

2. See which hdisks are in rootvg. In my case, hdisk0 and hdisk1 were part of rootvg.

AIX# lsvg
AIX# lspv
AIX# lspv -l disk1
AIX# lspv -l disk0

3. Remove one disk from the rootvg mirror:

AIX# unmirrorvg -c 1 rootfg hdisk0 #this unmirrors hdisk0, hdisk1 remains
AIX# reducevg rootvg hdisk0 # this removes hdisk0 from rootvg complete. Don’t use -d or -f
AIX# lspv -l hdisk0 #check to ensure hdisk0 is free

4. Install upgrade on the free disk. This takes a while (1-2 hours for me). This command copies rootvg (hdisk1) to hdisk0, and then applies the updates to disk0:

AIX# alt_disk_copy -d hdisk0 -b update_all -l

5. Reboot. This will boot off of hdisk0; hdisk0’s volume group will be renamed old_rootvg. Test and verify it works. Check OS level after reboot:

AIX# oslevel -r

If everything works properly, re-sync mirrors on rootvg
You can leave things in the two-disk state for a while. I left it for a few days. Once you’re sure you want to keep the changes, re-sync the mirrors.

IBM’s document on mirroring rootvg:
http://www-1.ibm.com/support/docview.wss?uid=isg3T1000358

AIX# alt_rootvg_op -X old_rootvg #This removes old_rootvg; hdisk1 is now accessable
AIX# extendvg rootvg hdisk1 #Add hdisk1 to rootvg; I had to use the -f force option
AIX# mirrorvg rootvg

Rebuild boot list; add hdisk0 and hdisk1 to bootlist; and reboot to disable the quorum:

AIX# bosboot -a
AIX# bootlist -m normal hdisk0 hisk1
AIX# reboot

Search for your disk (hdisk1 for me) in the boot log:

AIX# alog -o -t boot | less

Look at boot order:

bootlist -m normal -o #shows boot order

If things don’t look right, boot off of old_rootvg
Boot off of the old_rootvg disk (hdisk1). After a reboot, you should be able to see rootvg (which was the old one) and alt_rootvg (the new one that didn’t work).

Check which disk is in which vg, edit the boot order to make hdisk1 first, and then reboot:

AIX# lspv
AIX# bootlist -m normal -o hdisk1 hdisk0
AIX# reboot
AIX# oslevel -r

Comentarios